Utiliser Mysql avec Python3

Bonjour,

Le traditionnel paquet "mysql-python" n'est malheureusement compatible qu'avec la version 2.x de python. Dommage car la version 3 de python est maintenant très aboutie, et a de nombreux avantage. Alors non, je ne me résoudrai pas à repasser à la version 2 pour autant !

Inutile d'abandonner mysql pour autant, heureusement un fork a été créé, mysqlclient. Je l'ai testé et il fonctionne très bien. S'il n'est pas disponible dans les paquets de votre distribution, une commande magique :

sudo pip install mysqlclient

Et voilà, vous pouvez maintenant faire joujou entre python3 et mysql, ils se parlent 🙂

Note : suivant votre système, il faut utiliser pip3 et non pip (suivant la version de python par défaut)

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *