Débloquer son imprimante Canon en cas de manque d’encre

Chers internautes,

Peut-être que comme moi, un beau jour votre imprimante Canon vous a dit que votre cartouche jaune était vide, et qu'il fallait la changer. Ce message, vous n'avez pas pu l'éliminer, et tant qu'il est là, impossible d'utiliser l'imprimante, pas même pour scanner ! Bordel de squick* !

Dans mon cas, je ne souhaitais plus utiliser l'imprimante. Uniquement le scanner. Donc hors de question de racheter une cartouche. Peut-être aussi que vous déciderez par un élan d'économies d'imprimer désormais uniquement en noir et blanc ! Ou simplement vous avez envie de scanner alors que votre cartouche toute neuve n'est pas encore arrivée chez vous...

Dans ce cas, la solution est simple : quand ce message apparaît, appuyez sur le bouton STOP/RESET de l'imprimante jusqu'à ce qu'il disparaisse. Le tour est joué, l'imprimante est de nouveau utilisable. Le message n'apparaîtra plus, pas même aux prochains démarrage de l'imprimante.

L'opération est à renouveler pour chaque nouvelle cartouche d'encre qui deviendrait épuisée.

Source : http://www.inkbank.com.au/webcontent28.htm

*spéciale dédicace à la personne qui se reconnaîtra ^^

Utiliser Mysql avec Python3

Bonjour,

Le traditionnel paquet "mysql-python" n'est malheureusement compatible qu'avec la version 2.x de python. Dommage car la version 3 de python est maintenant très aboutie, et a de nombreux avantage. Alors non, je ne me résoudrai pas à repasser à la version 2 pour autant !

Inutile d'abandonner mysql pour autant, heureusement un fork a été créé, mysqlclient. Je l'ai testé et il fonctionne très bien. S'il n'est pas disponible dans les paquets de votre distribution, une commande magique :

sudo pip install mysqlclient

Et voilà, vous pouvez maintenant faire joujou entre python3 et mysql, ils se parlent 🙂

Note : suivant votre système, il faut utiliser pip3 et non pip (suivant la version de python par défaut)